setup.py 15.9 KB
Newer Older
1
2
#!/usr/bin/env python

3
# Copyright 2011-2015 Kwant authors.
4
#
Christoph Groth's avatar
Christoph Groth committed
5
6
# This file is part of Kwant.  It is subject to the license terms in the file
# LICENSE.rst found in the top-level directory of this distribution and at
7
# http://kwant-project.org/license.  A list of Kwant authors can be found in
Christoph Groth's avatar
Christoph Groth committed
8
# the file AUTHORS.rst at the top-level directory of this distribution and at
9
10
# http://kwant-project.org/authors.

11
from __future__ import print_function
Christoph Groth's avatar
Christoph Groth committed
12
13

import sys
14
import re
Christoph Groth's avatar
Christoph Groth committed
15
import os
16
import glob
17
import imp
Christoph Groth's avatar
Christoph Groth committed
18
19
import subprocess
import ConfigParser
Christoph Groth's avatar
Christoph Groth committed
20
21
from setuptools import setup, Extension, Command
from sysconfig import get_platform
Christoph Groth's avatar
Christoph Groth committed
22
23
from distutils.errors import DistutilsError, DistutilsModuleError, \
    CCompilerError
24
from distutils.command.build import build
Christoph Groth's avatar
Christoph Groth committed
25
26
from setuptools.command.sdist import sdist
from setuptools.command.build_ext import build_ext
27

28
29
30
31
32
33
try:
    import numpy
except ImportError:
    include_dirs = []
else:
    include_dirs = [numpy.get_include()]
Christoph Groth's avatar
Christoph Groth committed
34

35
36
CONFIG_FILE = 'build.conf'
README_FILE = 'README.rst'
Christoph Groth's avatar
Christoph Groth committed
37
MANIFEST_IN_FILE = 'MANIFEST.in'
38
README_END_BEFORE = 'See also in this directory:'
39
STATIC_VERSION_PATH = ('kwant', '_kwant_version.py')
Christoph Groth's avatar
Christoph Groth committed
40
REQUIRED_CYTHON_VERSION = (0, 22)
41
42
43
44
45
NO_CYTHON_OPTION = '--no-cython'
TUT_DIR = 'tutorial'
TUT_GLOB = 'doc/source/tutorial/*.py'
TUT_HIDDEN_PREFIX = '#HIDDEN'

46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
# Let Kwant itself determine its own version.  We cannot simply import kwant, as
# it is not built yet.
_dont_write_bytecode_saved = sys.dont_write_bytecode
sys.dont_write_bytecode = True
try:
    imp.load_source(STATIC_VERSION_PATH[-1].split('.')[0],
                    os.path.join(*STATIC_VERSION_PATH))
except IOError:
    pass
_common = imp.load_source('_common', 'kwant/_common.py')
sys.dont_write_bytecode = _dont_write_bytecode_saved

version = _common.version
version_is_from_git = _common.version_is_from_git

Christoph Groth's avatar
Christoph Groth committed
61
62
63
64
65
66
try:
    sys.argv.remove(NO_CYTHON_OPTION)
    cythonize = False
except ValueError:
    cythonize = True

67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
if cythonize:
    try:
        import Cython
    except:
        cython_version = ()
    else:
        match = re.match('([0-9.]*)(.*)', Cython.__version__)
        cython_version = [int(n) for n in match.group(1).split('.')]
        # Decrease version if the version string contains a suffix.
        if match.group(2):
            while cython_version[-1] == 0:
                cython_version.pop()
            cython_version[-1] -= 1
        cython_version = tuple(cython_version)

82
distr_root = os.path.dirname(os.path.abspath(__file__))
83

84
85
86
def banner(title=''):
    starred = title.center(79, '*')
    return '\n' + starred if title else starred
87

88
error_msg = """{header}
89
90
91
The compilation of Kwant has failed.  Please examine the error message
above and consult the installation instructions in README.rst.
You might have to customize {{file}}.
92

93
Build configuration was:
94

95
{{summary}}
96
97
98
{sep}
"""
error_msg = error_msg.format(header=banner(' Error '), sep=banner())
Christoph Groth's avatar
Christoph Groth committed
99

Christoph Groth's avatar
Christoph Groth committed
100

Christoph Groth's avatar
Christoph Groth committed
101
102
class kwant_build_ext(build_ext):
    def run(self):
103
104
105
106
107
108
109
110
        if not config_file_present:
            # Create an empty config file if none is present so that the
            # extensions will not be rebuilt each time.  Only depending on the
            # config file if it is present would make it impossible to detect a
            # necessary rebuild due to a deleted config file.
            with open(CONFIG_FILE, 'w') as f:
                f.write('# Created by setup.py - feel free to modify.\n')

Christoph Groth's avatar
Christoph Groth committed
111
112
113
        try:
            build_ext.run(self)
        except (DistutilsError, CCompilerError):
114
115
            print(error_msg.format(file=CONFIG_FILE, summary=build_summary),
                  file=sys.stderr)
Christoph Groth's avatar
Christoph Groth committed
116
            raise
117
        print(banner(' Build summary '))
118
        print(build_summary)
119
        print(banner())
Christoph Groth's avatar
Christoph Groth committed
120

121

122
class kwant_build_tut(Command):
123
124
125
126
127
128
129
130
131
132
133
134
135
136
    description = "build the tutorial scripts"
    user_options = []

    def initialize_options(self):
        pass

    def finalize_options(self):
        pass

    def run(self):
        if not os.path.exists(TUT_DIR):
            os.mkdir(TUT_DIR)
        for in_fname in glob.glob(TUT_GLOB):
            out_fname = os.path.join(TUT_DIR, os.path.basename(in_fname))
137
138
139
140
141
            with open(in_fname) as in_file:
                with open(out_fname, 'w') as out_file:
                    for line in in_file:
                        if not line.startswith(TUT_HIDDEN_PREFIX):
                            out_file.write(line)
142
143
144
145
146
147


# Our version of the "build" command also makes sure the tutorial is made.
# Even though the tutorial is not necessary for installation, and "build" is
# supposed to make everything needed to install, this is a robust way to ensure
# that the tutorial is present.
148
149
class kwant_build(build):
    sub_commands = [('build_tut', None)] + build.sub_commands
150

151
    def run(self):
152
        build.run(self)
153
154
        write_version(os.path.join(self.build_lib, *STATIC_VERSION_PATH))

155
156

def git_lsfiles():
157
    if not version_is_from_git:
158
159
        return

160
    try:
161
        p = subprocess.Popen(['git', 'ls-files'], cwd=distr_root,
162
163
164
165
166
167
168
                             stdout=subprocess.PIPE, stderr=subprocess.PIPE)
    except OSError:
        return

    if p.wait() != 0:
        return
    return p.communicate()[0].split('\n')[:-1]
169
170


171
172
173
174
# Make the command "sdist" depend on "build".  This verifies that the
# distribution in the current state actually builds.  It also makes sure that
# the Cython-made C files and the tutorial will be included in the source
# distribution and that they will be up-to-date.
175
176
class kwant_sdist(sdist):
    sub_commands = [('build', None)] + sdist.sub_commands
177
178

    def run(self):
Christoph Groth's avatar
Christoph Groth committed
179
180
181
182
183
184
185
186
187
188
        """
        Create MANIFEST.in from git if possible, otherwise check that MANIFEST.in
        is present.

        Right now (2015) generating MANIFEST.in seems to be the only way to
        include files in the source distribution that setuptools does not think
        should be there.  Setting include_package_data to True makes setuptools
        include *.pyx and other source files in the binary distribution.
        """
        manifest = os.path.join(distr_root, MANIFEST_IN_FILE)
189
190
        names = git_lsfiles()
        if names is None:
Christoph Groth's avatar
Christoph Groth committed
191
192
193
194
            if not (os.path.isfile(manifest) and os.access(manifest, os.R_OK)):
                print("Error:", MANIFEST_IN_FILE,
                      "file is missing and Git is not available"
                      " to regenerate it.", file=sys.stderr)
195
196
                exit(1)
        else:
Christoph Groth's avatar
Christoph Groth committed
197
            with open(manifest, 'w') as f:
198
199
200
201
202
                for name in names:
                    a, sep, b = name.rpartition('/')
                    if b == '.gitignore':
                        continue
                    stem, dot, extension = b.rpartition('.')
Christoph Groth's avatar
Christoph Groth committed
203
                    f.write('include {}'.format(name))
204
                    if extension == 'pyx':
Christoph Groth's avatar
Christoph Groth committed
205
206
                        f.write(''.join([' ', a, sep, stem, dot, 'c']))
                    f.write('\n')
207

208
        sdist.run(self)
209
210

        if names is None:
211
            print(banner(' Warning '),
212

Christoph Groth's avatar
Christoph Groth committed
213
214
        """Git was not available to generate the list of files to be included in the
source distribution.  The old MANIFEST.in was used.""",
215
                  banner(),
216
                  sep='\n', file=sys.stderr)
217

218
    def make_release_tree(self, base_dir, files):
219
        sdist.make_release_tree(self, base_dir, files)
220
        write_version(os.path.join(base_dir, *STATIC_VERSION_PATH))
221

Christoph Groth's avatar
Christoph Groth committed
222

223
224
225
def write_version(fname):
    # This could be a hard link, so try to delete it first.  Is there any way
    # to do this atomically together with opening?
226
    try:
227
228
229
230
231
232
        os.remove(fname)
    except OSError:
        pass
    with open(fname, 'w') as f:
        f.write("# This file has been created by setup.py.\n")
        f.write("version = '{}'\n".format(version))
Christoph Groth's avatar
Christoph Groth committed
233
234


235
236
237
238
239
def long_description():
    text = []
    try:
        with open(README_FILE) as f:
            for line in f:
240
                if line.startswith(README_END_BEFORE):
241
242
                    break
                text.append(line.rstrip())
243
244
            while text[-1] == "":
                text.pop()
245
246
247
248
249
    except:
        return ''
    return '\n'.join(text)


250
251
252
253
254
255
def packages():
    return [root.replace('/', '.')
            for root, dnames, fnames in os.walk('kwant')
            if '__init__.py' in fnames or root.endswith('/tests')]


256
257
258
259
260
261
262
263
264
265
266
267
def search_mumps():
    """Return the configuration for MUMPS if it is available in a known way.

    This is known to work with the MUMPS provided by the Debian package
    libmumps-scotch-dev."""

    libs = ['zmumps_scotch', 'mumps_common_scotch', 'pord', 'mpiseq_scotch',
            'gfortran']

    cmd = ['gcc']
    cmd.extend(['-l' + lib for lib in libs])
    cmd.extend(['-o/dev/null', '-xc', '-'])
Christoph Groth's avatar
Christoph Groth committed
268
    try:
269
        p = subprocess.Popen(cmd, stdin=subprocess.PIPE, stderr=subprocess.PIPE)
Christoph Groth's avatar
Christoph Groth committed
270
271
272
    except OSError:
        pass
    else:
273
274
275
        p.communicate(input='int main() {}\n')
        if p.wait() == 0:
            return {'libraries': libs}
Christoph Groth's avatar
Christoph Groth committed
276
277
278
279
    return {}


def extensions():
Christoph Groth's avatar
Christoph Groth committed
280
    """Return a list of tuples (args, kwrds) to be passed to Extension."""
Christoph Groth's avatar
Christoph Groth committed
281

282
    global build_summary, config_file_present
Christoph Groth's avatar
Christoph Groth committed
283
284
    build_summary = []

285
    #### Add components of Kwant without external compile-time dependencies.
Christoph Groth's avatar
Christoph Groth committed
286
287
288
289
290
291
292
293
294
295
296
297
298
299
300
301
302
303
304
305
    result = [
        (['kwant._system', ['kwant/_system.pyx']],
         {'include_dirs': ['kwant/graph']}),
        (['kwant.graph.core', ['kwant/graph/core.pyx']],
         {'depends': ['kwant/graph/core.pxd', 'kwant/graph/defs.h',
                      'kwant/graph/defs.pxd']}),
        (['kwant.graph.utils', ['kwant/graph/utils.pyx']],
         {'depends': ['kwant/graph/defs.h', 'kwant/graph/defs.pxd',
                      'kwant/graph/core.pxd']}),
        (['kwant.graph.slicer', ['kwant/graph/slicer.pyx',
                                 'kwant/graph/c_slicer/partitioner.cc',
                                 'kwant/graph/c_slicer/slicer.cc']],
         {'depends': ['kwant/graph/defs.h', 'kwant/graph/defs.pxd',
                      'kwant/graph/core.pxd',
                      'kwant/graph/c_slicer.pxd',
                      'kwant/graph/c_slicer/bucket_list.h',
                      'kwant/graph/c_slicer/graphwrap.h',
                      'kwant/graph/c_slicer/partitioner.h',
                      'kwant/graph/c_slicer/slicer.h']})]

306
    #### Add components of Kwant with external compile-time dependencies.
Christoph Groth's avatar
Christoph Groth committed
307
308
309
310
311
    config = ConfigParser.ConfigParser()
    try:
        with open(CONFIG_FILE) as f:
            config.readfp(f)
    except IOError:
312
313
314
        config_file_present = False
    else:
        config_file_present = True
Christoph Groth's avatar
Christoph Groth committed
315
316
317
318
319
320
321
322
323
324
325
326
327
328
329
330
331
332
333
334
335
336
337
338
339

    kwrds_by_section = {}
    for section in config.sections():
        kwrds_by_section[section] = kwrds = {}
        for name, value in config.items(section):
            kwrds[name] = value.split()

    # Setup LAPACK.
    lapack = kwrds_by_section.get('lapack')
    if lapack:
        build_summary.append('User-configured LAPACK and BLAS')
    else:
        lapack = {'libraries': ['lapack', 'blas']}
        build_summary.append('Default LAPACK and BLAS')
    kwrds = lapack.copy()
    kwrds.setdefault('depends', []).extend(
        [CONFIG_FILE, 'kwant/linalg/f_lapack.pxd'])
    result.append((['kwant.linalg.lapack', ['kwant/linalg/lapack.pyx']],
                   kwrds))

    # Setup MUMPS.
    kwrds = kwrds_by_section.get('mumps')
    if kwrds:
        build_summary.append('User-configured MUMPS')
    else:
340
        kwrds = search_mumps()
Christoph Groth's avatar
Christoph Groth committed
341
        if kwrds:
342
            build_summary.append('Auto-configured MUMPS')
Christoph Groth's avatar
Christoph Groth committed
343
344
345
346
347
348
349
350
351
352
353
354
355
356
    if kwrds:
        for name, value in lapack.iteritems():
            kwrds.setdefault(name, []).extend(value)
        kwrds.setdefault('depends', []).extend(
            [CONFIG_FILE, 'kwant/linalg/cmumps.pxd'])
        result.append((['kwant.linalg._mumps', ['kwant/linalg/_mumps.pyx']],
                       kwrds))
    else:
        build_summary.append('No MUMPS support')

    build_summary = '\n'.join(build_summary)
    return result


357
358
359
def complain_cython_unavailable():
    assert not cythonize or cython_version < REQUIRED_CYTHON_VERSION
    if cythonize:
360
361
        msg = ("Install Cython {0} or newer so it can be made\n"
               "or use a source distribution of Kwant.")
362
        ver = '.'.join(str(e) for e in REQUIRED_CYTHON_VERSION)
363
        print(msg.format(ver), file=sys.stderr)
364
    else:
365
366
        print("Run setup.py without {}.".format(NO_CYTHON_OPTION),
              file=sys.stderr)
367
368


Christoph Groth's avatar
Christoph Groth committed
369
370
371
def ext_modules(extensions):
    """Prepare the ext_modules argument for distutils' setup."""
    result = []
372
    problematic_files = []
Christoph Groth's avatar
Christoph Groth committed
373
    for args, kwrds in extensions:
374
        if not cythonize or cython_version < REQUIRED_CYTHON_VERSION:
375
376
            # Cython is not going to be run: replace pyx extension by that of
            # the shipped translated file.
Christoph Groth's avatar
Christoph Groth committed
377
378
379
380
381
382
            if 'language' in kwrds:
                if kwrds['language'] == 'c':
                    ext = '.c'
                elif kwrds['language'] == 'c++':
                    ext = '.cpp'
                else:
383
                    print('Unknown language', file=sys.stderr)
Christoph Groth's avatar
Christoph Groth committed
384
                    exit(1)
385
            else:
Christoph Groth's avatar
Christoph Groth committed
386
387
388
389
390
391
392
393
394
395
396
397
                ext = '.c'
            pyx_files = []
            cythonized_files = []
            sources = []
            for f in args[1]:
                if f[-4:] == '.pyx':
                    pyx_files.append(f)
                    f = f[:-4] + ext
                    cythonized_files.append(f)
                sources.append(f)
            args[1] = sources

398
            # Complain if cythonized files are older than Cython source files.
Christoph Groth's avatar
Christoph Groth committed
399
400
401
402
            try:
                cythonized_oldest = min(os.stat(f).st_mtime
                                        for f in cythonized_files)
            except OSError:
403
404
                print("error: Cython-generated file {} is missing.".format(f),
                      file=sys.stderr)
405
                complain_cython_unavailable()
406
                exit(1)
Christoph Groth's avatar
Christoph Groth committed
407
            for f in pyx_files + kwrds.get('depends', []):
408
409
410
411
                if f == CONFIG_FILE:
                    # The config file is only a dependency for the compilation
                    # of the cythonized file, not for the cythonization.
                    continue
Christoph Groth's avatar
Christoph Groth committed
412
                if os.stat(f).st_mtime > cythonized_oldest:
413
                    problematic_files.append(f)
Christoph Groth's avatar
Christoph Groth committed
414
415
416

        result.append(Extension(*args, **kwrds))

417
418
419
420
421
422
423
424
425
426
427
428
429
430
431
432
433
434
435
436
437
    if problematic_files:
        problematic_files = ", ".join(problematic_files)
        msg = ("Some Cython source files are newer than files that should have\n"
               " been derived from them, but {}.\n"
               "\n"
               "Affected files: {}")
        if cythonize:
            if not cython_version:
                reason = "Cython is not installed"
            else:
                reason = "the installed Cython is too old"
            print(banner(" Error "), msg.format(reason, problematic_files),
                  banner(), sep="\n", file=sys.stderr)
            print()
            complain_cython_unavailable()
            exit(1)
        else:
            reason = "the option --no-cython has been given"
            print(banner(" Warning "), msg.format(reason, problematic_files),
                  banner(), sep='\n', file=sys.stderr)

Christoph Groth's avatar
Christoph Groth committed
438
439
440
441
    return result

def main():
    setup(name='kwant',
442
          version=version,
443
444
          author='C. W. Groth (CEA), M. Wimmer, '
                 'A. R. Akhmerov, X. Waintal (CEA), and others',
445
          author_email='authors@kwant-project.org',
Christoph Groth's avatar
Christoph Groth committed
446
          description="Package for numerical quantum transport calculations.",
447
448
          long_description=long_description(),
          platforms=["Unix", "Linux", "Mac OS-X", "Windows"],
449
450
          url="http://kwant-project.org/",
          license="BSD",
451
          packages=packages(),
Christoph Groth's avatar
Christoph Groth committed
452
          test_suite = 'nose.collector',
453
          cmdclass={'build': kwant_build,
454
                    'sdist': kwant_sdist,
455
                    'build_ext': kwant_build_ext,
Christoph Groth's avatar
Christoph Groth committed
456
                    'build_tut': kwant_build_tut},
Christoph Groth's avatar
Christoph Groth committed
457
          ext_modules=ext_modules(extensions()),
458
          include_dirs=include_dirs,
Christoph Groth's avatar
Christoph Groth committed
459
460
461
          setup_requires=['numpy > 1.6.1', 'nose >= 1.0'],
          install_requires=['numpy > 1.6.1', 'scipy >= 0.9', 'tinyarray'],
          extras_require={'plotting': 'matplotlib >= 1.2'})
462

Christoph Groth's avatar
Christoph Groth committed
463
464
if __name__ == '__main__':
    main()