Commit 5292fa7b authored by Joseph Weston's avatar Joseph Weston
Browse files

bump qsymm requirement to 1.2.4

The test suite uses features from the 1.2 release of qsymm.
parent 1f0ee0b4
......@@ -45,7 +45,7 @@ a NumPy-like Python package optimized for very small arrays,
The following software is highly recommended though not strictly required:
* `matplotlib <http://matplotlib.org/>`_ 1.5.1 or newer, for the module `kwant.plotter` and the tutorial,
* `SymPy <http://sympy.org/>`_ 0.7.6 or newer, for the subpackage `kwant.continuum`.
* `Qsymm <https://pypi.org/project/qsymm/>`_ 1.1.0 or newer, for the subpackage `kwant.qsymm`.
* `Qsymm <https://pypi.org/project/qsymm/>`_ 1.2.4 or newer, for the subpackage `kwant.qsymm`.
* `MUMPS <http://graal.ens-lyon.fr/MUMPS/>`_, a sparse linear algebra library
that will in many cases speed up Kwant several times and reduce the memory
footprint. (Kwant uses only the sequential, single core version
......
......@@ -588,7 +588,7 @@ def main():
'plotting': 'matplotlib >= 1.5.1',
'continuum': 'sympy >= 0.7.6',
# qsymm is only packaged on PyPI
'qsymm': 'qsymm >= 1.1.2',
'qsymm': 'qsymm >= 1.2.4',
},
classifiers=[c.strip() for c in classifiers.split('\n')])
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment