Commit bde145b2 authored by Viacheslav Ostroukh's avatar Viacheslav Ostroukh 🚲
Browse files

require Python 3.7

Merge request !370 was supposed to make Python 3.7 minimal required version,
but in some places 3.6 sneaked from attention. This commit fixes that.
parent f2d3e41b
Pipeline #72581 passed with stages
in 50 minutes and 45 seconds
...@@ -169,7 +169,7 @@ Minimum required versions for some dependencies have increased ...@@ -169,7 +169,7 @@ Minimum required versions for some dependencies have increased
-------------------------------------------------------------- --------------------------------------------------------------
Kwant now requires at least the following versions: Kwant now requires at least the following versions:
+ Python 3.6 + Python 3.7
+ numpy 0.13.3 + numpy 0.13.3
+ scipy 0.19.1 + scipy 0.19.1
......
...@@ -528,7 +528,7 @@ def add_sys_includes_and_libs(exts): ...@@ -528,7 +528,7 @@ def add_sys_includes_and_libs(exts):
def main(): def main():
check_python_version((3, 6)) check_python_version((3, 7))
check_versions() check_versions()
exts = collections.OrderedDict([ exts = collections.OrderedDict([
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment