1. 01 Apr, 2022 1 commit
  2. 30 Mar, 2022 3 commits
  3. 24 Mar, 2022 1 commit
    • Bas Nijholt's avatar
      Fix ImportError for scipy 1.8.0 · 4a6830ff
      Bas Nijholt authored
      See
      - https://github.com/scipy/scipy/pull/15220
      - https://github.com/scipy/scipy/issues/14360
      
      
      Currently, it gives the following error message:
      ```
      ---------------------------------------------------------------------------
      ImportError                               Traceback (most recent call last)
      Input In [29], in <module>
      ----> 1 from scipy.sparse.linalg import linsolve
      
      ImportError: cannot import name 'linsolve' from 'scipy.sparse.linalg' (/nfshome/basnijholt/mambaforge/envs/qms-lab-20220224-main/lib/python3.9/site-packages/scipy/sparse/linalg/__init__.py)
      ```
      
      With this change, the following warning is emitted:
      ```
      /tmp/scratch/basnijholt/ipykernel_59547/2794395227.py:1: DeprecationWarning: The module `scipy.sparse.linalg.dsolve.linsolve` is deprecated. All public names must be imported directly from the `scipy.sparse.linalg` namespace.
        from scipy.sparse.linalg.dsolve import linsolve
      ```
      
      The following gives no warning:
      ```
      from scipy.sparse.linalg._dsolve import linsolve
      ```
      
      However, we should reconsider using private features.
      4a6830ff
  4. 24 Jun, 2021 1 commit
  5. 22 Jun, 2021 2 commits
  6. 21 Jun, 2021 4 commits
  7. 18 Jun, 2021 8 commits
  8. 17 Jun, 2021 9 commits
  9. 15 Jun, 2021 4 commits
  10. 14 Jun, 2021 2 commits
  11. 11 Jun, 2021 1 commit
  12. 18 Mar, 2021 1 commit
    • Viacheslav Ostroukh's avatar
      require Python 3.7 · bde145b2
      Viacheslav Ostroukh authored
      Merge request !370 was supposed to make Python 3.7 minimal required version,
      but in some places 3.6 sneaked from attention. This commit fixes that.
      bde145b2
  13. 03 Mar, 2021 1 commit
  14. 02 Mar, 2021 1 commit
  15. 20 Feb, 2021 1 commit