bump sympy version in the 'kwant-stable' testing environment

Qsymm requires sympy 1.1, even though Kwant proper only requires
sympy 0.7.6. In any case people on ultra-old Ubuntu or Debian
will have to install Qsymm via Conda or Pip anyway (which will
pull in the newer sympy version), and we already test against
the oldest versions of the minimal dependencies (without matplotlib,
sympy or qsymm) so this will not have a meaningful impact on our
test coverage.
22 jobs for feat/stable-testing-images in 9 minutes (queued for 3 seconds)
latest