Commit cec7d4a2 authored by Joseph Weston's avatar Joseph Weston

add qsymm to optional dependencies

Also update CI to install qsymm on relevant platforms, and update
pytest config to skip kwant.qsymm tests when qsymm is not installed
parent 4c1b6d75
......@@ -105,6 +105,7 @@ build-env:default:
before_script:
- source deactivate
- source activate kwant-latest
- pip install qsymm
- unset CFLAGS # https://github.com/conda-forge/toolchain-feedstock/issues/41
.bleeding-edge-env: &bleeding_edge_env
......@@ -112,13 +113,17 @@ build-env:default:
- source deactivate
- conda env update -f /kwant-latest.yml
- source activate kwant-latest
- pip install qsymm
.ubuntu-env: &ubuntu_env
image: gitlab.kwant-project.org:5005/kwant/kwant/ubuntu
before_script:
- pip3 install qsymm
.debian-env: &debian_env
image: gitlab.kwant-project.org:5005/kwant/kwant/debian
before_script:
- pip3 install qsymm
## Build Jobs
......
# Copyright 2011-2017 Kwant authors.
# Copyright 2011-2018 Kwant authors.
#
# This file is part of Kwant. It is subject to the license terms in the file
# LICENSE.rst found in the top-level directory of this distribution and at
......@@ -17,7 +17,8 @@ import importlib
# map from subpackage to sequence of dependency module names
subpackage_dependencies = {
'kwant/continuum': ['sympy']
'kwant/continuum': ['sympy'],
'kwant/tests/test_qsymm': ['qsymm', 'sympy'],
}
......
#!/usr/bin/env python3
# Copyright 2011-2017 Kwant authors.
# Copyright 2011-2018 Kwant authors.
#
# This file is part of Kwant. It is subject to the license terms in the file
# LICENSE.rst found in the top-level directory of this distribution and at
......@@ -586,6 +586,8 @@ def main():
# The oldest versions between: Debian stable, Ubuntu LTS
'plotting': 'matplotlib >= 1.5.1',
'continuum': 'sympy >= 0.7.6',
# qsymm is only packaged on PyPI
'qsymm': 'qsymm >= 1.1.2',
},
classifiers=[c.strip() for c in classifiers.split('\n')])
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment