Be more consistent in dependency specification
Kwant >=1.2 depends on python v3.4 released March 16th, 2014. At that time the following versions of scipy libraries already existed:
- matplotlib v1.3.1 (but we don't support it due to bugs).
- scipy v0.13.3.
- numpy v1.8.1.
The dependencies we list in setup.py are:
- mpl >=1.2.
- scipy >=0.11.0
- numpy > 1.6.1.
An obvious improvement would to bump all of these versions, but we can also consider being more proactive in increasing the dependencies if there is something to be gained.
EDIT: fixed the version numbers (I wasn't thorough enough checking them initially), and slightly rephrased the description.