change uses of 'Learner.tell' to 'Learner._tell' where appropriate

All occurances of 'add_point' before commit 58a30fe1 should be
'_tell' now, and 'add_data' should be 'tell'.

Fixes #58.
2 jobs for v0.4.1 in 2 minutes and 20 seconds (queued for 1 second)
latest