Commit 21b407d3 authored by Niket Agrawal's avatar Niket Agrawal
Browse files

Merge branch 'relax-package-version-pinning' into 'master'

Relax package version pinning

Closes #30

See merge request !11
parents 3477f260 0e8748ef
Pipeline #55524 failed with stages
in 16 minutes and 35 seconds
......@@ -6,6 +6,12 @@ and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0
## [Unreleased]
## [0.1.2] - 2021-03-09
### Fixed
+ Pinning of the patch version number of the packages, i.e., the dependencies of miniff, has been removed. Not fixing the patch version number facilitates receiving bug fixes for individual packages by requirements.txt/env.yml and update the environment during the installation. The overall consistency is still maintained as the major and minor version numbers continue to remain fixed.
## [0.1.1] - 2021-02-23
### Fixed
......
Cython==0.29.21
jupyter-sphinx==0.3.1
matplotlib==3.3.2
nose==1.3.7
Cython==0.29
jupyter-sphinx==0.3
matplotlib==3.3
nose==1.3
numericalunits==1.25
numpy==1.19.2
scipy==1.5.2
Sphinx==3.2.1
sphinx-rtd-theme==0.5.0
torch==1.6.0
\ No newline at end of file
numpy==1.19
scipy==1.5
Sphinx==3.2
sphinx-rtd-theme==0.5
torch==1.6
\ No newline at end of file
......@@ -4,14 +4,14 @@ channels:
- conda-forge
- defaults
dependencies:
- cython=0.29.21
- jupyter_sphinx=0.3.1
- matplotlib=3.3.2
- nose=1.3.7
- cython=0.29
- jupyter_sphinx=0.3
- matplotlib=3.3
- nose=1.3
- numericalunits=1.25
- numpy=1.19.2
- pytorch=1.6.0
- scipy=1.5.2
- sphinx=3.2.1
- sphinx_rtd_theme=0.5.0
- numpy=1.19
- pytorch=1.6
- scipy=1.5
- sphinx=3.2
- sphinx_rtd_theme=0.5
[build-system]
requires = ["setuptools", "wheel", "Cython>=0.29", "numpy>=1.18.4"]
\ No newline at end of file
requires = ["setuptools", "wheel", "Cython>=0.29", "numpy>=1.18"]
\ No newline at end of file
Cython==0.29.21
jupyter-sphinx==0.3.1
matplotlib==3.3.2
nose==1.3.7
Cython==0.29
jupyter-sphinx==0.3
matplotlib==3.3
nose==1.3
numericalunits==1.25
numpy==1.19.2
scipy==1.5.2
Sphinx==3.2.1
sphinx-rtd-theme==0.5.0
torch==1.6.0
\ No newline at end of file
numpy==1.19
scipy==1.5
Sphinx==3.2
sphinx-rtd-theme==0.5
torch==1.6
\ No newline at end of file
......@@ -157,7 +157,7 @@ class ext_modules_lazy(list):
setup(
name='miniff',
version='0.1.1',
version='0.1.2',
author='Artem Pulkin, Viacheslav Ostroukh '
'Niket Agrawal, André Melo, Anastasiia Varentcova',
author_email='gpulkin@gmail.com',
......@@ -169,11 +169,11 @@ setup(
long_description=open('README.md').read(),
ext_modules=ext_modules_lazy(),
install_requires=[
'numpy>=1.18.4',
'scipy>=1.4.1',
'numpy>=1.18',
'scipy>=1.4',
'numericalunits>=1.25',
'matplotlib>=3.2.1',
'torch>=1.5.1',
'matplotlib>=3.2',
'torch>=1.5',
],
scripts=[
],
......
Supports Markdown
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment