Verified Commit a4429734 authored by Hugo Kerstens's avatar Hugo Kerstens
Browse files

Use libdmtx-dev instead of version specific package

parent e5560aa0
......@@ -3,7 +3,7 @@
FROM continuumio/miniconda3
RUN apt-get update && \
apt-get install -y libdmtx0b && \
apt-get install -y libdmtx-dev && \
apt-get install -y git supervisor nginx cron
WORKDIR /app
......
......@@ -66,8 +66,7 @@ on different platforms:
| OS | Command |
|-------------------------------|---------------------------|
| macOS | `brew install libdmtx` |
| Debian <= 9, Ubuntu <= 19.04 | `apt install libdmtx0a` |
| Debian >= 10, Ubuntu >= 19.10 | `apt install libdmtx0b` |
| Debian, Ubuntu | `apt install libdmtx-dev` |
| Arch | `pacman -S libdmtx` |
| Fedora | `dnf install libdmtx` |
| openSUSE | `zypper install libdmtx0` |
......
......@@ -2,7 +2,7 @@
FROM continuumio/miniconda3
RUN apt-get update -y && apt-get install -y libdmtx0b nginx sudo
RUN apt-get update -y && apt-get install -y libdmtx-dev nginx sudo
RUN echo "server { listen 80; location / { proxy_pass http://127.0.0.1:5000; } }" > /etc/nginx/sites-enabled/proxy.conf
RUN rm /etc/nginx/sites-enabled/default
......
......@@ -2,7 +2,7 @@
FROM continuumio/miniconda3
RUN apt-get update -y && apt-get install -y libdmtx0b
RUN apt-get update -y && apt-get install -y libdmtx-dev
WORKDIR /app
......
......@@ -3,7 +3,7 @@
FROM continuumio/miniconda3
RUN apt-get update && \
apt-get install -y libdmtx0b
apt-get install -y libdmtx-dev
WORKDIR /yarn
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment