Commit 50613422 authored by Joseph Weston's avatar Joseph Weston

downgrade required scipy version to 0.19

parent 730d9e37
Pipeline #23963 passed with stage
in 2 minutes and 42 seconds
......@@ -4,7 +4,7 @@ channels:
dependencies:
- python=3.5
- numpy=1.13
- scipy=1.1.0
- scipy=0.19
- sympy=1.1
- tinyarray
## Dev Dependencies
......
......@@ -10,9 +10,13 @@ if sys.version_info < (3, 5):
sys.exit(1)
# These requirements should not be updated to versions more
# recent than required by Kwant:
# https://gitlab.kwant-project.org/kwant/kwant/blob/master/setup.py#L584
# because we want to remain interoperable
install_requires = [
'numpy>=1.13', # because we use __array_ufunc__
'scipy>=1.1.0', # because we use reshape for sparse matrices
'scipy>=0.19',
'sympy>=1.1',
'tinyarray',
]
......
Markdown is supported
0%
or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment